Tuicemen.com

Advanced search  

News:

Alex10  (Build 1.5.3.5 ) is now  available for download ~:0~

Pages: [1]

Author Topic: Alex10 V1.5.2.5 Discussion  (Read 340 times)

alzy

  • Sr. Member
  • ***
  • Helpful Rating: 0
  • Offline Offline
  • Posts: 168
Alex10 V1.5.2.5 Discussion
« on: February 26, 2017, 04:52:57 am »

I noticed that when Alex10 writes to bridge, the parenthetical "{intensity.percent}" is not written as part of the expression. Is that the way it should be?

Also, the cm19a seems to Dim/Brighten the last device turned on by it not the one selected in the UI.

Also with my soft start wall switch, it still appears that once it Dims to zero, it must be reset to some level at the wall to further be controlled by UI. The UI in any case dims it even if Bri is selected
Logged

Tuicemen

  • Administrator
  • Hero Member
  • *****
  • Helpful Rating: 24
  • Offline Offline
  • Posts: 3142
  • Making Home Automation Fun!
    • Tuicemen.com
Re: Alex10 V1.5.2.5 Discussion
« Reply #1 on: February 26, 2017, 06:09:25 am »

I noticed that when Alex10 writes to bridge, the parenthetical "{intensity.percent}" is not written as part of the expression. Is that the way it should be?
No it should be writing the "{intensity.percent}" Did you use the update from Alex10 or the full installer?

Try a new install and see if that fixes or manually add till next update.
[/quote]
Quote
Also, the cm19a seems to Dim/Brighten the last device turned on by it not the one selected in the UI.
I don't know why that would be happening unless the data.db file or X10DeviceSettings.xml is corrupt.
I've see the data.db file get corrupt on occasion but usually the Bridge stops working.
The Data.db file is referenced by Alex10 only to compare devices in the X10DeviceSettings.xml file to see if the device is actually a x10 device.
if the device isn't in the X10DeviceSettings.xml file then Alex10 tells the Bridge to send the command.
Quote
Also with my soft start wall switch, it still appears that once it Dims to zero, it must be reset to some level at the wall to further be controlled by UI. The UI in any case dims it even if Bri is selected
Softstart modules/switches do pose extra issues.
Remember the bridge still sees a device even if dimmed to zero as ON.
SoftStart devices come on to their last state.
With the Softstart devices I tested both the Dim and Bri worked as intended. However to be fair I never used the CM19 in testing :-[
Alex10 wasn't intended to be used full time by the UI. Device control from the UI was primarily intended as a test simular to what the bridge has though it has evolved into more.

I'll dig out my Cm19 again and test your findings though I don't have a SoftStart wall switch to play with.
Logged
Get the inside scoop and member perks in the
Members Only Section!

Please don't email me Automation questions 
The forum is for that!

Tuicemen

  • Administrator
  • Hero Member
  • *****
  • Helpful Rating: 24
  • Offline Offline
  • Posts: 3142
  • Making Home Automation Fun!
    • Tuicemen.com
Re: Alex10 V1.5.2.5 Discussion
« Reply #2 on: February 26, 2017, 06:37:46 am »

Ok ran a few quick tests with the CM19.
Thought I can't recreate your issues I'll keep it connected for the day.

I did notice some strange things in development which may be contributing to some of your Issues.
I found if when adding a device in Alex10 that the named device wasn't exactly the same in the bridge it wouldn't trip the device and would sometimes trip a completely different device.
The device names in the Bridge and Alex10 are case sensitive.
This shouldn't happen unless you perform some manual editing.

When you add a device with Alex10 or the bridge. Alexa must be told to discover devices.
Also On occasion the bridge required a refresh from it's interface (this seemed to be a random thing).

Usually a refresh from the Bridge interface will reveal a database error sometimes displaying a blank device or not displaying any devices.
If it displays a blank device deleting that device usually repairs the device.db file

I was able to replicate corrupting the DB file from issuing repeated dim commands.(however that is fixed)
Prior to this update Alex10 wasn't removing the trailing decimals in all cases.
The Bridge doesn't know how to handle decimals, so the db file got corrupt.

Logged
Get the inside scoop and member perks in the
Members Only Section!

Please don't email me Automation questions 
The forum is for that!

alzy

  • Sr. Member
  • ***
  • Helpful Rating: 0
  • Offline Offline
  • Posts: 168
Re: Alex10 V1.5.2.5 Discussion
« Reply #3 on: February 26, 2017, 06:54:53 am »

I used the installer. So I tried again. I did a complete uninstall of Alex10 including deleting its folder and then did a fresh install. Still not writing the parenthetical to bridge for Dim.
Logged

Tuicemen

  • Administrator
  • Hero Member
  • *****
  • Helpful Rating: 24
  • Offline Offline
  • Posts: 3142
  • Making Home Automation Fun!
    • Tuicemen.com
Re: Alex10 V1.5.2.5 Discussion
« Reply #4 on: February 26, 2017, 06:58:59 am »

Ok I'll check the code again.
I'll also recreate the installer and repost it.
Logged
Get the inside scoop and member perks in the
Members Only Section!

Please don't email me Automation questions 
The forum is for that!

Tuicemen

  • Administrator
  • Hero Member
  • *****
  • Helpful Rating: 24
  • Offline Offline
  • Posts: 3142
  • Making Home Automation Fun!
    • Tuicemen.com
Re: Alex10 V1.5.2.5 Discussion
« Reply #5 on: February 26, 2017, 07:17:29 am »

Ok tested the installer there was defiantly something wrong there.
the code it's self was good.
I recreated both the update and full setups files and 1.5.2.6 is now on the server
Only change to the code is a update button located in the about screen so if users update popup doesn't work (for what ever reason) a update can be performed from there.
 (Chr)
Logged
Get the inside scoop and member perks in the
Members Only Section!

Please don't email me Automation questions 
The forum is for that!

alzy

  • Sr. Member
  • ***
  • Helpful Rating: 0
  • Offline Offline
  • Posts: 168
Re: Alex10 V1.5.2.5 Discussion
« Reply #6 on: February 26, 2017, 09:19:15 am »

Looks like 1526 is loading bridge with parenthetical now and Alexa Voice control executes Dim
Logged

Tuicemen

  • Administrator
  • Hero Member
  • *****
  • Helpful Rating: 24
  • Offline Offline
  • Posts: 3142
  • Making Home Automation Fun!
    • Tuicemen.com
Re: Alex10 V1.5.2.5 Discussion
« Reply #7 on: February 26, 2017, 09:25:22 am »

Good to know. :)!
Not sure why the installers worked from here but not from the server. :o
Maybe a over write issue on the server ??? ::) :`)
Logged
Get the inside scoop and member perks in the
Members Only Section!

Please don't email me Automation questions 
The forum is for that!

alzy

  • Sr. Member
  • ***
  • Helpful Rating: 0
  • Offline Offline
  • Posts: 168
Re: Alex10 V1.5.2.5 Discussion
« Reply #8 on: February 26, 2017, 10:44:19 am »

Thanks for all your effort! :0~
Logged

Tuicemen

  • Administrator
  • Hero Member
  • *****
  • Helpful Rating: 24
  • Offline Offline
  • Posts: 3142
  • Making Home Automation Fun!
    • Tuicemen.com
Re: Alex10 V1.5.2.5 Discussion
« Reply #9 on: February 26, 2017, 10:49:52 am »

Thanks for all your effort! :0~
Thank you for catching and reporting! :)!
 (Chr)
Logged
Get the inside scoop and member perks in the
Members Only Section!

Please don't email me Automation questions 
The forum is for that!

Tuicemen

  • Administrator
  • Hero Member
  • *****
  • Helpful Rating: 24
  • Offline Offline
  • Posts: 3142
  • Making Home Automation Fun!
    • Tuicemen.com
Re: Alex10 V1.5.2.5 Discussion
« Reply #10 on: February 28, 2017, 05:50:32 am »

Been running with the cm19 steady without issues for a few days now.
I just noticed a new HA-Bridge is available so I've installed it to see if it creates any issues.
I'll keep the cm19 connected while testing.
Since this thread was for version 1.5.2.5 I'll close it.
 (Chr)
Logged
Get the inside scoop and member perks in the
Members Only Section!

Please don't email me Automation questions 
The forum is for that!
Pages: [1]